MySQL 5.6.23 und Windows 8.1

Ich bin wahrscheinlich mittlerweile zu alt für diesen…
Nach der Aktualisierung des PCs von Windows 7 auf Windows 8.1 habe ich MySQL 5.6.23 neu installieren müssen. Das ist mir mit den meisten Programmen beim Umstieg auf Windows 8.1 so ergangen. Ich dachte, ich mache ein Update von Windows 7 auf Windows 8.1, als ich die Installation direkt unter Windows startete, aber Update ist eben nicht Update… Doch zurück zum Thema „MySQL 5.6.23 und Windows 8.1“. Der erste Schritt führte mich auf die MySQL-Homepage um mir den neuen Installer zu besorgen. Unter Windows 7 hatte ich noch die Version 5.6.14 im Einsatz. Eine Aktualisierung auf die neue 5.6.23 kann nicht schaden… dachte ich mir.

Die Installation war – sagen wir mal – anstrengend. Ich habe den Installer ca. ein Dutzend mal aufgerufen um die richtigen Produkte installieren zu können. Neben einem offensichtlichen Bug bei der Wahl des Installationspaketes (siehe Bild), hat der Installer auch wirklich Probleme, wenn es auf der Disk schon MySQL-Verzeichnisse oder Installationen gibt*!2015-04-03 17_28_19-MySQL Installer

(Abb. der Installer kennt keine Produkte, die zur Auswahl „Full“ Installation passen)

* An dieser Stelle möchte ich anmerken, dass es nicht sonderlich zeitsparend war, Windows 8.1 einfach über Windows 7 zu installieren. Man richtet alle Programme trotzdem neu ein, lediglich die paar Daten, in der Regel auf einer anderen Partition befindlich, wurden erhalten. Eine Neuinstallation wäre besser gewesen!

Letztendlich bekam ich den MySQL Server auf die Platte indem ich jegliche Verzeichnisse, die mit MySQL zu tun hatten, komplett vom Laufwerk entfernte und alles „frisch“ neu installierte. Ich habe mich dabei zuletzt auf die Server-Komponente beschränkt. Weitere Tools wie z.B. die MySQL Workbench kann man anschließend installieren.

Nach der Installation des Servers sollte genau überprüft werden, ob auch alle Einstellungen, die über  den Installer vorgenommen wurden, auch greifen. Ich hatte im Installer angegeben, dass mein Daten-Verzeichnis unter D:\Daten\MySQL\Data liegt – dort hatte ich schon einige DBs aus der alten Installation liegen.
Nach dem Start des Servers wollte dieser aber nichts von den DBs wissen und bot mir lediglich die „test“-DB an.
Über folgenden Befehl habe ich mir die Konfiguration des Dienstes angesehen:

sc qc mysql
[SC] QueryServiceConfig ERFOLG

SERVICE_NAME: mysql
 TYPE : 10 WIN32_OWN_PROCESS
 START_TYPE : 2 AUTO_START
 ERROR_CONTROL : 1 NORMAL
 BINARY_PATH_NAME : "C:\Program Files\MySQL\MySQL Server 5.6\bin\mysqld
.exe" --defaults-file="C:\ProgramData\MySQL\MySQL Server 5.6\my.ini" MYSQL
 LOAD_ORDER_GROUP :
 TAG : 0
 DISPLAY_NAME : MYSQL
 DEPENDENCIES :
 SERVICE_START_NAME : NT AUTHORITY\NetworkService

Im Gegensatz zur Beispieldatei „my-defaults.ini“, die im Programm-Verzeichnis abgelegt wird, wird die eigentliche INI-Datei unter „C:\ProgramData\MySQL\MySQL Server 5.6\“ abgelegt. In dieser Datei war natürlich kein Hinweis auf meinen im Installer angegebenen DB-Pfad zu finden.

Dienst gestoppt. „datadir“ angepasst. Dienst gestartet: Datenbanken wieder da.

Als nächstes macht die Workbench Ärger. Zwar habe ich über die installierte Version 6.2.5.0 build 397 (64 bits) Zugriff auf meine DBs und kann auch ganz gut entwickeln, abfragen und testen – Grundlegende DB-Einstellungen lassen sich aber nicht steuern. Das Tool beharrt auf eine INI-Datei für meinen SQL-Server unter C:\Program Files\MySQL\MySQL Server 5.0\my.ini“ – doch das wird eine andere Geschichte.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Bitte folgende kleine Aufgabe lösen: * Time limit is exhausted. Please reload CAPTCHA.